Credential verification slowness and impact on live meetings

Incident Report for Proof

Resolved

This incident has been resolved.
Posted Nov 26, 2024 - 13:47 EST

Update

We are continuing to monitor for any further issues.
Posted Nov 26, 2024 - 13:35 EST

Update

We are continuing to monitor for any further issues.
Posted Nov 26, 2024 - 13:27 EST

Monitoring

One of Proof's credential analysis services experienced performance degradation earlier today. As a result, ID verification steps for some users between 12:30 to 1:15 pm ET were taking longer than expected, affecting meeting acceptance. We already observed a recovery to normal latencies and volumes. The team is monitoring and working with the vendor, expecting full recovery shortly.
Posted Nov 26, 2024 - 13:25 EST
This incident affected: Notarize Consumer App (iOS), Proof Consumer (Web), Notarize Consumer App (Android), and Proof Real Estate.