Service Outage - Signers reporting that they are unable to verify their identity and enter a meeting

Incident Report for Proof

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 14:10 EDT

Monitoring

As of approximately 1:44 PM ET, we became aware of a serious issue affecting the ability for signers to successfully complete the identity verification process and enter meetings. The third-party service used for identity verification was experiencing an outage.

The issue has been resolved and signers are again able to enter meetings. We will continue to monitor the service.
Posted Apr 15, 2025 - 14:01 EDT
This incident affected: Notarize Consumer App (iOS), Proof Consumer (Web), Notarize Consumer App (Android), and Proof Real Estate.