Delayed document completion on Proof platform due to digital certificate vendor outage

Incident Report for Proof

Resolved

We are observing sustained recovery of document completion on Proof platform. Most of the delayed documents were processed successfully. We will continue to monitor the health of the application, together with our vendor. We apologize for any inconvenience this incident might have caused.
Posted Sep 02, 2025 - 18:19 EDT

Update

We are observing a recovery for the last 15 minutes, but do not assume yet it will be sustained. Documents should be completing at the moment. We will continue working with our vendor this evening to ensure a permanent solution.
Posted Sep 02, 2025 - 17:14 EDT

Update

Unfortunately after some period of recovery, we are seeing an increase in errors and document completion delays again. This incident is not fully resolved yet.
Posted Sep 02, 2025 - 16:11 EDT

Monitoring

We are seeing broader recovery, document completions are back to normal levels. We are expediting the processing of the delayed processing jobs.
Posted Sep 02, 2025 - 15:18 EDT

Update

We received an update from our vendor that they identified a root cause and are working on a fix. We are observing early signs of partial recovery but cannot confirm full recovery yet. We will prioritize completing delayed documents as soon as it is feasible.
Posted Sep 02, 2025 - 14:59 EDT

Update

Most document completions continue to be delayed, with a few exceptions. We do not have a resolution time estimate at this moment.
Posted Sep 02, 2025 - 14:05 EDT

Update

We continue to investigate this problem together with our vendor. Document completion is still delayed, and will be re-processed as soon as the root cause issue is addressed.
Posted Sep 02, 2025 - 13:26 EDT

Identified

Completions for certain documents and meetings on Proof platform have been delayed since 12:20 PM Eastern. We are working with our vendor to restore the functionality. Once the issue is addressed, the documents and meetings will be automatically processed.
Posted Sep 02, 2025 - 12:52 EDT
This incident affected: Proof Consumer (Web), Proof/Notarize API, Proof Real Estate, and Notary Platform.