Proof platform - real estate closing incident due to eVault service outage

Incident Report for Proof

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 21:32 EST

Investigating

Proof platform is experiencing an incident impacting real estate closings due to eVault service outage. We estimate impact as partial, affecting only some users. We will provide another update in an hour or less.
Posted Feb 19, 2026 - 21:01 EST
This incident affected: Proof Real Estate.