No new occurrences of the issue have been identified during the monitoring period. The issue has been resolved.
Posted Jul 14, 2026 - 15:20 EDT
Monitoring
We're now seeing continued successful requests and completions from our primary KBA vendor and believe that services have been fully restored. We will continue to monitor their success rates.
Posted Jul 14, 2026 - 14:45 EDT
Update
The 3rd-party vendor continues to make progress in recovering their services, but we continue to experience issues with some of their services. We will continue to provide status updates as they become available.
Posted Jul 14, 2026 - 14:30 EDT
Identified
Beginning around 11:00 AM ET, we noticed a situation of degraded performance in our primary KBA service provider which resulted in some transaction recipients not receiving KBA questions. This can impact some user's ability to enter a meeting with a notary or result in a delay in entering a meeting. Our engineering team is actively investigating and we will provide more details as we have them.
Posted Jul 14, 2026 - 12:59 EDT
This incident affected: Notarize Consumer App (iOS), Proof Consumer (Web), and Notarize Consumer App (Android).