Document completion delays and errors due to certificate provider outage

Incident Report for Proof

Resolved

This incident has been resolved. All backlogged documents were completed.
Posted Jul 31, 2025 - 12:40 EDT

Monitoring

We are observing recovery. New documents are being completed, and the backlog of previously failed completions is being worked through.
Posted Jul 31, 2025 - 12:22 EDT

Identified

We heard back from our certificate vendor that their systems are being restored; however, we continue to observe a partial outage relating to document finalization. Proof Platform will continue to accept, process and complete meetings. Document completion will continue to be delayed for some time, but will be recovered automatically once the issue is fully addressed.
Posted Jul 31, 2025 - 11:58 EDT

Investigating

Starting at 11:00 am Eastern time, Proof platform is experiencing document completion errors. This could result in a delay of meeting completions and document signings. We are working with our vendor to fix the problem as soon as possible. Once addressed, the documents should automatically complete.
Transaction preparation and sending is not impacted.
Posted Jul 31, 2025 - 11:40 EDT
This incident affected: Notarize Consumer App (iOS), Proof Consumer (Web), Notarize Consumer App (Android), Proof/Notarize API, Proof Real Estate, and Notary Platform.