Document completion delays on Proof platform

Incident Report for Proof

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 17:07 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2026 - 16:50 EDT

Identified

We identified a problem with digital signing of PDF documents on Proof platform. The impact is delayed completion of the documents after the meeting or e-sign operation. We are working with our vendor to restore the functionality.

We expect all documents to automatically process after the resolution.
Posted Apr 08, 2026 - 16:25 EDT
This incident affected: Proof Consumer (Web), Proof/Notarize API, Proof Real Estate, and Notary Platform.