Degraded performance with identity verification

Incident Report for Proof

Resolved

The vendor has resolved the issue. Our service is functioning normally now.
Posted Feb 04, 2026 - 16:16 EST

Monitoring

The vendor has restored full service. We are seeing our system go back to normal. We will continue to monitor.
Posted Feb 04, 2026 - 16:02 EST

Identified

We are currently experiencing degraded performance with one of our identity verification vendors. The ability for signers to complete some transaction types may be impacted.
Posted Feb 04, 2026 - 15:39 EST
This incident affected: Notarize Consumer App (iOS), Proof Consumer (Web), Notarize Consumer App (Android), and Proof Real Estate.